Peugeot 2008 Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,

New to the forum


Bought my 2008 1.6 Allure last month and am having problems activating the grip control.
I dont know if im being stupid, but the wee knob for choosing what type of grip control i require does not seem to turn at all. Should this just happen when the car is turned on and stationary? Doesnt matter when i try and turn it, it wont budge.

Any help would be appreciated before i call servicing department??

Thanks

Frazer
 

·
Registered
Joined
·
1,081 Posts
This problem has been reported at least once before. I swear that we had one owner that had this problem who reported the cause, but I can't find that thread.

Maybe if you did a search it may come up. Otherwise you might need a trip to the dealers.
 

·
Registered
Joined
·
37 Posts
It definitely should turn - whether the car is running or stationary. It is only the outside 'ring' which turns - the inside bit which has the icons doesn't turn, but the outside ring should turn pretty easily.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Yeah i've actually noticed that its able to turn after 20-30 minute journey the last 2 days. Apart from that nada.I'm wondering if its linked to battery as was having problems with an engine fault when i picked up the car and it turned out to be low voltage in the battery.
Anyway its away in to the servicing dept today so hopefully they can figure out exactly whats going on.
 
1 - 4 of 4 Posts
Top