Peugeot 2008 Forums banner

1 - 20 of 29 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I've done a few quick topic searches and can't seem to find this thread... So apologies if this has been discussed to death already!
I've had my 2008 for a little over a month now and I've noticed the touchscreen cutting out (screen going black) and then seeming to reset itself - goes through the same start up as when you first turn the car on.

Anyone else experienced this issue before??

Thanks :)
 

·
Registered
Joined
·
49 Posts
Yes mine does that when it was out for test drive re gearbox whine it did it twice, the mechanic said how often does it do that I said quite often, another thing that needs looking into.
I was hoping that a firmware update would solve it but with other problems have not had it it looked at yet.
 

·
Registered
Joined
·
1,081 Posts
Mine has only ever done it once in a year.

How old is the Car? It shouldn't do it so best get it looked at and updated if there is later firmware available.
 

·
Registered
Joined
·
72 Posts
Had mine since Feb 14, it has reset about 6 times, normally it freezes or crashes and you can't change volume etc then it reboots. I don't think its a problem its just like all computers and gets its knickers in a twist.

If you hold the button above the menu button in you can force a restart anyway.
 

·
Registered
Joined
·
1 Posts
Hi,

How long do you have to hold the button above the menu button to restart?

Yesterday, I drove to the airport and my display crashed. I had no music, no sat nav and no clock the whole way to the airport. There was no auto reboot, and turning the engine off and on did not sort the problem.

I am hoping that when I fly back, either the problem will have gone away, or I will figure out how to reboot the display. I have a 400 mile road-trip on wednesday next week, and I need the sat nav. I have no time to get to a dealer.

I have searched the manual, and the internet, but I cannot find any instructions to fix this problem.

Thanks in advance
Martin
 

·
Registered
Joined
·
2,035 Posts
I'd ring my dealer whilst waiting in the departure lounge and ask for assistance/suggestions over the phone.

Hopefully you will return with the necessary information to hand.
 

·
Registered
Joined
·
273 Posts
Driving through the New Forest today, listening to our local BBC radio station when I heard a bang. Thought that a small branch had hit the roof, but no,the touch screen had gone totally blank. After about 5 minutes it rebooted itself and eventually the radio came back on. The noise I had heard presumably came from the speakers. Have I mentioned before that these cars seem to have a mind of their own?
 

·
Registered
Joined
·
23 Posts
I had this problem 5 times today, but only when a route was programmed into the sat nav. Has anyone else noticed this?
Later I did a factory reset and so far everything seems to be working ok.
 

·
Registered
Joined
·
70 Posts
Slightly off topic but has anybody else had this problem, when i connect my iPhone to the usb my radio then does what i can only describe as running at 33rpm instead of 45rpm, it carries on doing this until the iPhone connects to the stereo and then everything is fine.
 

·
Registered
Joined
·
23 Posts
I have had this problem twice now but only when a route is entered into the sat nav. First time was last Tuesday 7th April, after six attempts to enter the route successfully I eventually tried a factory reset and success everything was back to normal, that is until to day. In the morning everything worked ok, able to program route etc. On the way home the same problem occurred the system reset whenever a route was entered. Carrying out a factory reset cleared the problem. I bought the car from new in December 2013.
I think a trip to the dealer is in order.
 

·
Registered
Joined
·
23 Posts
I have had this problem twice now but only when a route is entered into
the sat nav. First time was last Tuesday 7th April, after six attempts
to enter the route successfully I eventually tried a factory reset and
success everything was back to normal, that is until to day. In the
morning everything worked ok, able to program route etc. On the way home
the same problem occurred the system reset whenever a route was
entered. Carrying out a factory reset cleared the problem. I bought the
car from new in December 2013.
I think a trip to the dealer is in order.
 

·
Registered
Joined
·
398 Posts
A few days ago I have experimented a delay in GPS maps, also radio slow down...I have changed the Color so the system rebooted, and all back to normal...Seems that happens when you enter in GPS Navigation on uncharted roads...or if stays a lot with recalculation ( I knew the road that was new, and ignored GPS indications with "turn around" for 15 minutes...he revenged ... :))) )
 

·
Registered
Joined
·
23 Posts
Went to the dealer today to discuss the problem. From the reaction of the staff I had the impression that Peugeot is aware of problems with the sat nav/media system. I will post the outcome next Tuesday - 21st.
 

·
Registered
Joined
·
23 Posts
Progress report:- took car to the garage at the appointed time, 10:30, waited for 1 & 3/4 hours only to be told that Peugot had not yet released the software update that should fix the problem with the sat nav & DAB radio. Also the dealer has no idea for potential release date.
 

·
Registered
Joined
·
398 Posts
All are the same...In order to fix a bug, they research half year...stupid things...If was Android system on car, I bet all bugs were fixed in no-time :))))...also a lot of smart gadgets would appear...
 
1 - 20 of 29 Posts
Top